1. 首页
  2. 交易所公告

关于OKEx启用HTTP/2和禁用TLS/1.0、TLS/1.1的说明

一、OKEx将支持HTTP2协议:

1、为了提高用户体验,OKEx全站(WEB和API)将于2020年2月20日14:00 (HKT)支持 HTTP/2。HTTP/2更简单,高效,强大。目前HTTP/2被很多服务端和客户端应用在服务系统当中。

2. 客户端不受影响,如果客户端不支持HTTP/2,系统会自行选择HTTP/1.1进行通信。

 

二、OKEx将禁用TLS/1.0、TLS/1.1协议:

1、由于TLS/1.0、TLS/1.1协议版本存在安全隐患,为保障用户交易和资产安全,OKEx全站(WEB和API)将于2020年2月20日14:00 (HKT)禁用TLS/1.0、TLS/1.1协议;

2、对客户端影响:任何依旧使用TLS/1.0、TLS/1.1协议入站链接到OKEx的浏览器用户和OpenAPI用户将会被拒绝访问,为了您的交易不受影响,请您提前升级至TLS/1.2。

3、客户端相关软件对TLS/1.2兼容性说明

软件

软件版本

兼容性说明

java

 

Java 8 (oracle) 和更高版本

默认兼容 TLS/1.2

Java 7 (oracle)

 

默认不容兼TLS/1.2,建议升级到java8或更高版本,也可以采用三方包bouncycastle解决,

不便升级时也可通过以下属性设置来兼容:

1、-Dhttps.protocols=TTLSv1.2  (适用于HttpsURLConnection方式);

2、或者在应用程序源代码中的已创建 SSLSocket 和 SSLEngine 实例上启用TLS1.2协议。

 

Java 6 (oracle)

不兼容TLS/1.2,建议升级到java8或更高版本,也可以采用三方包bouncycastle解决。

Dot NET

Dot NET 4.6 和更高版本

默认兼容 TLS/1.2

NET 4.5 至 4.5.2

默认不兼容,该版本可在软件代码中直接启用 TLS/1.2。

建议通过设置 System.Net.ServicePointManager.SecurityProtocol 启用 SecurityProtocolType.Tls12,C# 示例:

System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls;

 

Dot NET 4.0

默认不兼容,建议升级到新版本和更改注册表来兼容:

将以下两个注册表项中的 SchUseStrongCrypto DWORD 值设置为 1(如果不存在请创建):”HKEY_LOCAL_MACHINESOFTWAREMicrosoft.NETFrameworkv4.0.30319″ 和 “HKEY_LOCAL_MACHINESOFTWAREWow6432NodeMicrosoft.NETFrameworkv4.0.30319”

Dot NET 3.5 和更低版本

不兼容TLS/1.2,建议升级到新版本

Python

Python 2.7.9 和更高版本

默认兼容 TLS/1.2或高版本

Python 2.7.8 和更低版本

不兼容TLS/1.2,建议升级到新版本

Ruby

Ruby 2.0.0+OpenSSL 1.0.1

默认兼容 TLS/1.2或高版本

Ruby 1.9.3 和更低版本

不兼容TLS/1.2,建议升级到新版本,或为Ruby打补丁

Nodejs

Nodejs

各版本均支持

Golang

Golang1.7.4和更高版本

默认兼容TLS/1.2

Chrome

Chrome 38 和更高版本

默认兼容TLS/1.2

Chrome 30 至 37

在 Windows XP SP3、Vista 或更高版本(桌面)、OS X 10.6 OS X 10.6 (Snow Leopard) 或更高版本(桌面)或 Android 2.3 (Gingerbread) 或更高版本(移动)中运行时兼容。

Chrome 29 和早期版本

不兼容TLS/1.2,建议升级到新版本

Firefox

Firefox 27 和更高版本

默认兼容TLS/1.2

Firefox 24 至 26

兼容,但并非默认设置。

使用 about:config 为TLS/1.2 将 security.tls.version.max config 值更新为 3,以启用TLS/1.2。

Firefox 23 和早期版本

不兼容TLS/1.2,建议升级到新版本

Safari

OS X 10.9 (Mavericks) 和更高版本的桌面 Safari 版本 7 和更高版本

默认兼容TLS/1.2

OS X 10.8 (Mountain Lion) 和早期版本的桌面 Safari 版本 6 和早期版本

不兼容TLS/1.2

iOS 5 和更高版本的移动 Safari 版本 5 和更高版本

默认兼容TLS/1.2

iOS 4 和早期版本的移动 Safari

不兼容TLS/1.2

IE

Microsoft Edge桌面和移动 IE 版本 11

默认兼容TLS/1.2

桌面 IE 版本 8、9 和 10

默认不兼容TLS/1.2,请在 Internet Explorer 中启用TLS 1.2 加密。

 

 

原创文章,作者:比特币区块链日报,如若转载,请注明出处:https://www.dailybtc.cn/%e5%85%b3%e4%ba%8eokex%e5%90%af%e7%94%a8http-2%e5%92%8c%e7%a6%81%e7%94%a8tls-1-0%e3%80%81tls-1-1%e7%9a%84%e8%af%b4%e6%98%8e/

发表评论

电子邮件地址不会被公开。 必填项已用*标注

联系我们

在线咨询:点击这里给我发消息

邮件:[email protected]

工作时间:周一至周五,9:30-18:30,节假日休息

QR code